Unverified70% confidenceDecision RuleExact time
If package.json specifies ^2.0.15, npm/pnpm will only pull 2.0.16 on reinstall; if a package-lock.json or pnpm-lock.yaml already exists, it stays unchanged, and you must explicitly run npm update @ai-sdk/zai or delete the lockfile and reinstall.
2
Sources
70%
Confidence
Long-term
Relevance
10/29/2026
First Seen
Sources
Related Entities
Related Claims
UnverifiedWhen using a caret-prefixed dependency range such as ^3.0.0 in package.json, npm/yarn/pnpm will automatically resolve to the latest compatible patch version during installation, while projects using exact version locking need to upgrade manually76% similarUnverifiednpm 使用 package-lock.json,pnpm 使用 pnpm-lock.yaml,Yarn 使用 yarn.lock,Bun 使用 bun.lockb(二进制格式)作为锁文件74% similarUnverifiedIf package.json uses caret or tilde version ranges, running npm update or reinstalling dependencies will automatically fetch @ai-sdk/xai 3.0.14068% similarUnverifiedWhen a dependency is declared in package.json in the form ^5.0.0, npm automatically selects the latest patch version within the same major version during installation.65% similarUnverifiedIn the npm ecosystem, using the ^ prefix in package.json (e.g., ^2.0.22) means that npm install will automatically pull the latest MINOR and PATCH updates under the same MAJOR version.64% similar
Cite This Claim
Stable URI
https://kongchang.com/claim/1112151API
curl https://kongchang.com/api/v1/knowledge/claims/1112151MCP
get_claim(id=1112151)